Back to overview
Degraded

General and PowerHub Services are down

Sep 10 at 05:10pm GMT-3
Affected services
General
PowerHub Services

Resolved
Sep 10 at 08:14pm GMT-3

General and PowerHub Services recovered.

Created
Sep 10 at 05:10pm GMT-3

General and PowerHub Services are degraded.