Back to overview
Degraded

PowerHub Services is down

Sep 22, 2025 at 1:34pm UTC
Affected services
PowerHub Services

Resolved
Sep 22, 2025 at 1:40pm UTC

PowerHub Services recovered.

Created
Sep 22, 2025 at 1:34pm UTC

PowerHub Services is degraded.