Back to overview
Degraded

General, PowerHub Services, and 1 other service are down

Oct 27, 2025 at 7:56am UTC
Affected services
General
PowerHub Services
PowerHub UI

Resolved
Oct 27, 2025 at 8:02am UTC

PowerHub UI recovered.

Updated
Oct 27, 2025 at 8:01am UTC

General and PowerHub Services recovered.

Updated
Oct 27, 2025 at 7:58am UTC

General is degraded.

Created
Oct 27, 2025 at 7:56am UTC

PowerHub Services and PowerHub UI are degraded.