Back to overview
Degraded

General and PowerHub Services are down

Nov 6, 2025 at 2:46am UTC
Affected services
General
PowerHub Services

Resolved
Nov 6, 2025 at 3:47am UTC

General and PowerHub Services recovered.

Updated
Nov 6, 2025 at 2:46am UTC

General is degraded.

Created
Nov 6, 2025 at 2:46am UTC

PowerHub Services is degraded.