Back to overview
Degraded
General and PowerHub Services are down
Apr 4, 2026 at 5:15am UTC
Affected services
General
PowerHub Services
Resolved
Apr 4, 2026 at 5:31am UTC
PowerHub Services recovered.
Affected services
Updated
Apr 4, 2026 at 5:27am UTC
PowerHub Services is degraded.
Affected services
Updated
Apr 4, 2026 at 5:19am UTC
General and PowerHub Services recovered.
Affected services
Created
Apr 4, 2026 at 5:15am UTC
General and PowerHub Services are degraded.
Affected services