Back to overview
Degraded
General and PowerHub Services are down
Apr 17, 2026 at 11:39pm UTC
Affected services
General
PowerHub Services
Resolved
Apr 17, 2026 at 11:46pm UTC
General and PowerHub Services recovered.
Affected services
Updated
Apr 17, 2026 at 11:39pm UTC
General is degraded.
Affected services
Created
Apr 17, 2026 at 11:39pm UTC
PowerHub Services is degraded.
Affected services