Back to overview
Degraded
General and PowerHub Services are down
Jun 8, 2026 at 5:24pm UTC
Affected services
General
PowerHub Services
Resolved
Jun 8, 2026 at 5:47pm UTC
General and PowerHub Services recovered.
Affected services
Updated
Jun 8, 2026 at 5:24pm UTC
General is degraded.
Affected services
Created
Jun 8, 2026 at 5:24pm UTC
PowerHub Services is degraded.
Affected services