Back to overview
Resolved

General, PowerHub Services, and 1 other service are down

Jun 19, 2026 at 11:48pm UTC
Affected services
General
PowerHub Services
PowerHub UI

Resolved
Jun 22, 2026 at 8:55pm UTC

General and PowerHub Services recovered.

Updated
Jun 22, 2026 at 2:07pm UTC

PowerHub UI recovered.

Updated
Jun 22, 2026 at 10:36am UTC

PowerHub UI is degraded.

Updated
Jun 22, 2026 at 10:23am UTC

PowerHub UI recovered.

Updated
Jun 22, 2026 at 9:24am UTC

PowerHub UI is degraded.

Updated
Jun 22, 2026 at 9:16am UTC

PowerHub UI recovered.

Updated
Jun 22, 2026 at 5:24am UTC

PowerHub UI is degraded.

Updated
Jun 22, 2026 at 5:16am UTC

PowerHub UI recovered.

Updated
Jun 21, 2026 at 8:09pm UTC

PowerHub UI is degraded.

Updated
Jun 21, 2026 at 8:01pm UTC

PowerHub UI recovered.

Updated
Jun 20, 2026 at 4:27am UTC

PowerHub UI is degraded.

Updated
Jun 20, 2026 at 4:19am UTC

PowerHub UI recovered.

Updated
Jun 20, 2026 at 1:51am UTC

PowerHub UI is degraded.

Updated
Jun 20, 2026 at 1:46am UTC

PowerHub UI recovered.

Updated
Jun 19, 2026 at 11:52pm UTC

PowerHub UI is degraded.

Created
Jun 19, 2026 at 11:48pm UTC

General and PowerHub Services are degraded.