Back to overview
Resolved

General and PowerHub Services are down

Jul 7, 2026 at 3:48am UTC
Affected services
General
PowerHub Services

Resolved
Jul 7, 2026 at 12:19pm UTC

General and PowerHub Services recovered.

Updated
Jul 7, 2026 at 3:54am UTC

General is degraded.

Created
Jul 7, 2026 at 3:48am UTC

PowerHub Services is degraded.